# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(
\#[\da-f]{3}
|\#[\da-f]{6}
|rgba\(
((\d{1,2}|1\d\d|2([0-4]\d|5[0-5]))\s*,\s*){2}
((\d{1,2}|1\d\d|2([0-4]\d|5[0-5]))\s*)
(,\s*(0\.\d+|1))
\)
|hsla\(
\s*((\d{1,2}|[1-2]\d{2}|3([0-5]\d|60)))\s*,
\s*((\d{1,2}|100)\s*%)\s*,
\s*((\d{1,2}|100)\s*%)
(,\s*(0\.\d+|1))
\)
|rgb\(
((\d{1,2}|1\d\d|2([0-4]\d|5[0-5]))\s*,\s*){2}
((\d{1,2}|1\d\d|2([0-4]\d|5[0-5]))\s*)
|hsl\(
\s*((\d{1,2}|[1-2]\d{2}|3([0-5]\d|60)))\s*,
\s*((\d{1,2}|100)\s*%)\s*,
\s*((\d{1,2}|100)\s*%)
\)
)$
"""
test_str = ("#ffffff\n"
"#nothing\n"
"#AF12AA\n"
"rgba(222, 222, 222)\n"
"RgBa(72,73,75)\n"
"hsl(0, 100%, 100%)\n"
"rgba(1024, 1024, 10)\n"
"#ffffff\n"
"#ffffffasdf\n"
"asdf#ffffff\n"
"rgba(170,221,255,0.59)\n"
"rgba(170,221,255,0.59)asdf\n"
"rgb(0, 0, 0)\n"
"asdfrgb(0, 0, 0)\n"
"rgb(0, 0, 0)asdf\n"
"hsla(208, 56%, 46%, 1)\n"
"hsla(208, 56%, 46%, 1)asdf\n"
"asdfhsla(208, 56%, 46%, 1)\n"
"hsl(208,56%,46%)asdf\n"
"asdfhsl(208,56%,46%)")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.