import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[1-9]\\d|0\\d[1-9]|6[0-57-9]\\d|6\\d[0-57-9]|[1-57-8]\\d\\d)-\\d{2}-\\d{4}$";
final String string = "123-45-6789\n"
+ "123456789\n"
+ "001341343\n"
+ "888-03-1785\n"
+ "888-04-0001\n"
+ "606-04-0001\n"
+ "660-04-0001\n\n"
+ "666-23-1234\n"
+ "666231234\n"
+ "000-65-1343\n"
+ "000651343\n"
+ "905-31-6375\n"
+ "905316375\n"
+ "888-00-1785\n"
+ "888001785\n"
+ "888-04-0000\n"
+ "888040000\n"
+ "666-00-0000\n"
+ "666-01-4050";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}