$re = '/^ActiveDirectory--User--([a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*)--Password$/m';
$str = 'ActiveDirectory--User--Smith--Password
ActiveDirectory--User--Sm--ith--Password';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);