$re = '/([0-9][-][0-9]{2,3}.*[A-Za-z])/';
$str = '1-10 Klinische Untersuchung
1-100Klinische Untersuchung in Allgemeinanästhesie
Hinw.:Die Allgemeinanästhesie ist im Kode enthalten
Dieser Kode ist nur dann zu verwenden, wenn die Untersuchung unter Anästhesie als
selbständige Maßnahme durchgeführt wird. Erfolgt in der gleichen Sitzung ein invasiver
oder operativer Eingriff, der eine Anästhesie erfordert, ist die Untersuchung nicht gesondert
zu kodieren
Untersuchung einzelner Körpersysteme
(1-20...1-33)
Hinw.:Das Anästhesieverfahren bei einer diagnostischen Maßnahme kann zusätzlich kodiert werden, sofern die
diagnostische Maßnahme üblicherweise ohne Allgemeinanästhesie durchgeführt wird (8-90)
1-20 Neurologische Untersuchungen
Hinw.:Das neurologische Monitoring ist gesondert zu kodieren (8-92)
1-202Diagnostik zur Feststellung des irreversiblen Hirnfunktionsausfalls
Hinw.:Diese Kodes sind nur zu verwenden bei Diagnostik nach der jeweils gültigen Fortschreibung
der Richtlinie der Bundesärztekammer zur Feststellung des irreversiblen
Hirnfunktionsausfalls (siehe im Zusammenhang mit einer Organspende auch § 5 und § 16
Abs. 1 Satz 1 Nr. 1 Transplantationsgesetz)
Die durchgeführten Einzelmaßnahmen sind nicht gesondert zu kodieren
1-202.0Bei einem potenziellen Organspender
Hinw.:Als Datum der Leistungserbringung ist das Datum anzugeben, an welchem mit der
Diagnostik des irreversiblen Hirnfunktionsausfalls begonnen wurde
Nicht angegeben werden dürfen diese Kodes, wenn der Patient zu Lebzeiten einer möglichen
Organspende widersprochen hat oder medizinische Kontraindikationen für eine
Organspende vorliegen
.00Ohne Feststellung des irreversiblen Hirnfunktionsausfalls
.01Mit Feststellung des irreversiblen Hirnfunktionsausfalls';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);