use strict;
my $str = 'ßßß While there was troublein town 333 wäs, nöö, söö, sää sü üs the 12 Tus tus people decided to let the love in their door. säwööo kk.
While there was troublein town 333 wäs, nöö, söö, sää sü üs the 12 Tus tus people decided to let the love in their door. säwööo kk. äöü ÄÖÜ ßßß';
my $regex = qr/(?<=^|\s)([\p{L}\p{N}]{3})(?=[\s.,]+|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}