re = /output:\D+\K\d(?:\.\d+)?/m
str = 'Approxmiate output size of output: 2.268 kilobytes
some entirely different string: 2.268 kilobytes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end