re = /\bqt(?![cy]).*?(\d{3})(?<![\d<>]\d{})(?:\D|$)/mi
str = 'EKG done this AM with QT 560 and QTC wnl at 535ms, higher than on exam performed 5/3/2015 which showed...
EKG done this AM with QT 560 and QTC wnl at 535ms, higher than on exam performed 5/3/2015 which showed...
QT560
015" from 5/3/2015
QT: 560
qt 5/3/2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end