const regex = /(^(\d)\2*?(?!\2)\d\2*?$)|(^(\d)(?!\4)(\d)\5+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(\\d)\\2*?(?!\\2)\\d\\2*?$)|(^(\\d)(?!\\4)(\\d)\\5+$)', 'gm')
const str = `44474
2272
23333
121
212222
55555
1234
2211
323332
1331`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}