#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)SID_W_MAX_TRAN_DT.+?=(?=\s) (?<SID_W_MAX_TRAN_DT>[^\s]+)"
Local $sString = "MID_COUNT =========== 20,588,655" & @CRLF & _
" % Total % Received % Xferd Average Speed Time Time Time Current" & @CRLF & _
" Dload Upload Total Spent Left Speed" & @CRLF & _
"Table.+.+?(?=\.)\W*(schema.table_name)\W.+?(?=,+)\,\s+numRows\=+(?<LogTime>[^\,]+)" & @CRLF & _
"" & @CRLF & _
"Loading data to table schema.table_name" & @CRLF & _
"Table gmr.opcode_tedc_cs_gmr_id_delta stats: [numFiles=5, numRows=8986691, totalSize=937732401, rawDataSize=928745710]" & @CRLF & _
"" & @CRLF & _
" 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0" & @CRLF & _
"100 997 100 997 0 0 114k 0 --:--:-- --:--:-- --:--:-- 162k" & @CRLF & _
"" & @CRLF & _
" 0 0 0 397 0 0 1650 0 --:--:-- --:--:-- --:--:-- 1650" & @CRLF & _
"SID_W_MAX_TRAN_DT ========== 9,070,691" & @CRLF & _
" % Total % Received % Xferd Average Speed Time Time Time Current" & @CRLF & _
" Dload Upload Total Spent Left Speed" & @CRLF & _
"" & @CRLF & _
" 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0" & @CRLF & _
"100 997 100 997 0 0 108k 0 --:--:-- --:--:-- --:--:-- 139k" & @CRLF & _
"" & @CRLF & _
" 0 0 0 403 0 0 944 0 --:--:-- --:--:-- --:--:-- 944" & @CRLF & _
"NON_PSP_SID_COUNT =========== 39,869,169" & @CRLF & _
" % Total % Received % Xferd Average Speed Time Time Time Current" & @CRLF & _
" Dload Upload Total Spent Left Speed" & @CRLF & _
"" & @CRLF & _
" 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0" & @CRLF & _
"100 997 100 997 0 0 112k 0 --:--:-- --:--:-- --:--:-- 162k" & @CRLF & _
"" & @CRLF & _
" 0 0 0 398 0 0 7223 0 --:--:-- --:--:-- --:--:-- 7223" & @CRLF & _
"PSP_SID_COUNT =========== 45,083" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")