re = /^(?=^abc)(?=.*xyz$)(?=.*123).*$/m
str = 'abc123xyz
wset123
abcwerf123cwerfxyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end