$re = '%^(?:\t| {4})\K(\$\w+)%m';
$str = 'class MyClass {
$myvar1;
// some comment here (even with a variable $x;)
$myvar2;
/* I have a multiline comment here
with a variable $x; here
*/
$myvar3;
# Just another comment $x;
$myvar4;
const SOMETHING;
$myvar5;
function __construct($myvar1 = NULL, $myvar2 = array()) {
$this->myvar1 = $myvar1;
$myvar6;
$this->myvar2 = $myvar2;
}
$myvar6;
}';
$subst = "private $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;