$re = '/\+?(254|0)7|(254|0)1\d{8}
/';
$str = '0768738765';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);