// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?\b(?:\d{3}|\D+)\.\w{3}$").unwrap();
let string = "File name without 3 digit end.jpg
File name with 3 digit 123.gif
Single 123.jpg
Single.png
Single 1.jpg
Single 123b.gif
More words 123b.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}