re = /^([a-zA-Z ]+),([0-9]|10),([0-9]|10),([0-9]|10),([0-9]|10),([0-9]|10),([0-9]|10)/
str = 'The Killer,6,7,3,6,8,1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end