re = /({{(?:(?!{{|}}).|(?1))*}})/m
str = 'This {is {{Par}m1}} plus {{Par{m3a{{Parm3b}}}} a}nd {{Parm4a||{{Par}m4b||{{Parm4c||{{Parm4d||Parm}}}}}}}}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end