import re
regex = re.compile(r"safari-extension:\/\/com\.wondershare\.ultimate-[a-zA-Z0-9]+\/[a-zA-Z0-9]+\/core\.js", flags=re.MULTILINE)
test_str = ("safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js\n"
"safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")