#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*?(?:\d+\*?(?:\d+#?)?)?$"
Local $sString = "123" & @CRLF & _
"*123#" & @CRLF & _
"*123*4#" & @CRLF & _
"" & @CRLF & _
"*" & @CRLF & _
"*123*4#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")