// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[0-9]{1,3}\.){3}[0-9]{1,3})\s((?:[0-9]{1,3}\.){3}[0-9]{1,3})").unwrap();
let string = "<140>Mar 21 09:50:26 Biblica-M400 80DA036A10A65 (2019-03-21T15:50:26) firewall: msg_id=\"3000-0148\" Allow 60-GUEST WIRELESS 0-External 60 tcp 20 63 172.16.60.35 192.243.232.7 38076 443 offset 10 S 936012176 win 65535 geo_dst=\"USA\" (Outgoing-00)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}