$re = '/^(?!(?:ftp|https?):\/\/(www\.)?).+$/m';
$str = 'xxxx.xxxx.xxxx
ftp://www.xxzx.com/xxx.aspx
https://www.xxzx.com/xxx.aspx
http://xxxx.com
https://xxzx.com/xxx.aspx
http://www.xxxx.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);