import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(^(?:www))|(?:ftp|https?):\\/\\/(www\\.)?).+$";
final String string = "xxxx.xxxx.xxxx\n"
+ "ftp://www.xxzx.com/xxx.aspx\n"
+ "https://www.xxzx.com/xxx.aspx\n"
+ "http://xxxx.com\n"
+ "https://xxzx.com/xxx.aspx\n"
+ "www.xxxx.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}