import re
regex = re.compile(r"(http://.*?)(?=\sxmlns|>)", flags=re.MULTILINE)
test_str = ("<soapenv:Envelope xmlns:soapenv=http://schemas.xmlsoap.org/soap/envelope/ xmlns:soap=http://www.4cgroup.co.za/soapauth xmlns:gen=http://www.4cgroup.co.za/genericsoap>\n")
subst = "\"\\1\""
result = regex.sub(subst, test_str)
if result:
print(result)