import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(house|car)(?: (?!(?:house|car)\\b)\\w+){1,10} (house|car)\\b";
final String string = "car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house\n"
+ "house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car\n\n\n"
+ "house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car\n\n"
+ "car test car\n"
+ "house test house\n"
+ "house house house\n"
+ "car car car\n"
+ "this is a test house riding a new car\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}