using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=!\[[^][]*[a-z])(?=[A-Z][^][]*])";
string substitution = @" ";
string input = @"
%s/\v(!\[[^][]*[a-z])@<=([A-Z][^][]*])@=/ /g
positive lookarounds in Vim: (atom)@<= (atom)@=";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}