$re = '/[A-Za-z0-9]*(\.php)?$/m';
$str = 'about
news.php
someimage.jpg
mystyle.css';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);