package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\btest\b`)
var str = `This is a test.
The testing was good.
The tester was bad.
package.test.com
skkg@test.com
Regex-test-is tough
"rm/_HOST@DEV.HADOOP.R1-CORE.R1.TEST.NET"
/Users/dattem/Desktop/DevCenter/test/ssl/
The test is today.
Name -test one`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}