use strict;
my $str = 'this is due on 2021-12-02 at 10:00 am
this is due on 2021/12/02 at 10:00 am
this is due on 2021.12.02 at 10:00 am';
my $regex = qr/(?P<date>((19|20)\d{2})[./-](0[1-9]|1[012])[./-](0[1-9]|[12][0-9]|3[01]))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}