$re = '/^(?!(.)\1{3})[a-zA-Z]{4}.*/m';
$str = 'aaaa
zzzz
abaaa test
a123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);