import re
regex = re.compile(r"(DEBUG|INFO|WARNING|ERROR):\s(\d{2}/.+-\d{4}) (\[\w+\])\s([^:]+):\s(.+) by (.+)\s(\w+@\w+\..+)")
test_str = "DEBUG: 01/31/2020 09:00:00 PM -0800 [ABC] meltdown occurred: stomped by George Farrel george@hotmail.com"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")