$re = '/\b[cpyrau]*T\d(?:(?![a-c]N)[a-oqstv-z]){0,2}/m';
$str = 'pT1c
cT4bcN2
cT3cN2
T1C
T1cN3
rapyT4abc
T4ssN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);