import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{1,2}+:[0-9]{1,2}+:[0-9]{1,2}+\\.[0-9]{1,3}+.*REST REQUEST(?:\\n[^\\S\\n]*\\S.*)+";
final String string = "12:56:13.861 [http-nio-7777-exec-1] INFO dg.mpro.filter.CustomRequestLoggingFilter - REST REQUEST\n"
+ "NUMBERS OF REQUESTS:= [1]\n"
+ "METHOD:= [GET]\n"
+ "PARAMETERS & VALUES :=\n"
+ "REQUEST:= [/rest/indexv2/getMetadata]\n"
+ "12:56:13.861 [http-nio-7777-exec-1] INFO dg.mpro.filter.CustomRequestLoggingFilter - Response time: 1 seconds\n\n"
+ "13:14:46.049 [http-nio-7777-exec-2] INFO dg.mpro.filter.CustomRequestLoggingFilter - REST REQUEST\n"
+ "NUMBERS OF REQUESTS:= [2]\n"
+ "METHOD:= [GET]\n"
+ "PARAMETERS & VALUES := [pagesize:= 20][name:= Mosolv][page:= 1][tolerance:= 4]\n"
+ "REQUEST:= [/rest/indexv2/getProds/{{licensekey}}/{{username}}/%7B%22tolerance%22:%224%22,%22pagesize%22:%2220%22,%22name%22:%22Mosolv%22,%22page%22:%221%22%7D]\n"
+ "13:14:46.050 [http-nio-7777-exec-2] INFO dg.mpro.filter.CustomRequestLoggingFilter - Response time: 2 seconds\n\n"
+ "12:57:14.812 [http-nio-7777-exec-1] INFO dg.mpro.filter.CustomRequestLoggingFilter - REST REQUEST\n"
+ "NUMBERS OF REQUESTS:= [3]\n"
+ "METHOD:= [GET]\n"
+ "PARAMETERS & VALUES :=\n"
+ "REQUEST:= [/rest/indexv2/getMetadata]\n"
+ "12:57:14.813 [http-nio-7777-exec-1] INFO dg.mpro.filter.CustomRequestLoggingFilter - Response time: 1 seconds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}