$re = '/ab(?:(?!ab?|c[bd]?|bc).)*?ec(?:(?!ab|bc).)*bc/m';
$str = 'abecbc
abcbc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);