package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A[^\w\W]`)
var str = `akdjalsdkjandl
jkj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}