// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(md5|0x)?[a-f0-9]{32}").unwrap();
let string = "0xff2902a2b61535ac9b6d61f82dc2a095
ff2902a2b61535ac9b6d61f82dc2a095
md5ff2902a2b61535ac9b6d61f82dc2a095";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}