$re = '/^(?!.*--)[a-zA-Z].{1,22}[a-z0-9A-Z]$/m';
$str = 'testingname01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);