import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\"|\\')(?<key>[\\w\\d]+)(?:\\\"|\\')(?:\\:\\s*)(?:\\\"|\\')?(?<value>[\\w\\s-]*)(?:\\\"|\\')?";
final String string = "{\n"
+ " \"Users\": {\n"
+ " \"RCYzpiJLRkcUfaPi7Pxu1OxGFTi2\": {\n"
+ " \"Active\": \"ON\",\n"
+ " \"Country\": \"country1\",\n"
+ " \"Email\": \"email1\",\n"
+ " \"ID\": \"RCYzpiJLRkcUfaPi7Pxu1OxGFTi2\",\n"
+ " \"Img\": \"imglink1\",\n"
+ " \"UserName\": \"username1\",\n"
+ " \"videos491375\": \"videolink1\",\n"
+ " \"videos748628\": \"videolink2\"\n"
+ " },\n"
+ " \"ZqOOX8nUSuVYI9YY9jkub22kWTP2\": {\n"
+ " \"Active\": \"ON\",\n"
+ " \"Country\": \"country2\",\n"
+ " \"Email\": \"username2\",\n"
+ " \"ID\": \"ZqOOX8nUSuVYI9YY9jkub22kWTP2\",\n"
+ " \"Img\": \"imglink1\",\n"
+ " \"UserName\": \"username2\",\n"
+ " \"videos1096589\": \"videolink1\",\n"
+ " \"videos12385\": \"videolink2\",\n"
+ " \"videos552833\": \"videolink3\"\n"
+ " },\n"
+ " \"ZqOOX8nUSuVYI9YY9jkub22kWTP2\": {\n"
+ " \"Active\": \"ON\",\n"
+ " \"Country\": \"country3\",\n"
+ " \"Email\": \"email3\",\n"
+ " \"ID\": \"ZqOOX8nUSuVYI9YY9jkub22kWTP2\",\n"
+ " \"Img\": \"imglink\",\n"
+ " \"UserName\": \"username3\",\n"
+ " },\n"
+ " \"mJozWrOKLqgdUPpZhZfinIxiKy92\": {\n"
+ " \"Active\": \"ON\",\n"
+ " \"Country\": \"country4\",\n"
+ " \"Email\": \"emailuser\",\n"
+ " \"ID\": \"mJozWrOKLqgdUPpZhZfinIxiKy92\",\n"
+ " \"Img\": \"imglink\",\n"
+ " \"UserName\": \"username4\",\n"
+ " \"videos361534\": \"videolink1\"\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}