import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<train>((<\\[[^a-zA-Z0-9]*\\]\\.){1})((\\.\\[[a-zA-Z0-9]*\\]\\.))*)$";
final String string = "<[@].\n"
+ "<[)$-{,]..[PB1N]..[R757G].\n"
+ "<[]..[]..[10]..[223F]..[GBM4].\n"
+ "<[!]..[]\n"
+ "<[)_]..[3N]..[TS]..[0NS58].\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}