const regex = /from(=<[^\s@<>]+@[^\s@<>]+>)\s*to\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('from(=<[^\\s@<>]+@[^\\s@<>]+>)\\s*to\\1', 'gm')
const str = `from=<test@test.ch> to=<test@test.ch>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}