import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<!--|-->)([\\s\\S]*?)-->";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<body>\n\n\n"
+ "<button onclick=\"myFunction()\">Try it</button>\n\n"
+ "<textarea id=\"demo\"></textarea>\n"
+ "<!-- das\n"
+ "i\n"
+ "s\n"
+ "t\n"
+ "ein terst\n\n"
+ "e-->\n"
+ "<script>\n"
+ "// hallo\n\n\n"
+ "function myFunction() {\n\n"
+ " \n"
+ " var str = document.documentElement.outerHTML;\n"
+ " alert(str);\n"
+ " var a = '<!-'+'-';\n"
+ " var b = '--'+'>';\n"
+ " var n = str.indexOf(a)+4;\n"
+ " var end = str.lastIndexOf(b)-1;\n"
+ " var xout= str.slice(n,end);\n"
+ " \n"
+ " document.getElementById(\"demo\").innerHTML = xout;\n\n\n\n\n"
+ "}\n\n\n"
+ "</script>\n\n\n"
+ "<template id=\"t1\">\n"
+ "fdff\n"
+ "<!-- das\n"
+ "i\n"
+ "s\n"
+ "t\n"
+ "ein test\n"
+ "g\n"
+ "f-->\n"
+ "fgfd\n"
+ "</template>\n\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}