$re = '/^(?=[A-Za-z])[A-Za-z\.\-\']{0,79}[A-Za-z\']$/m';
$str = 'abc.\'
abc-\'.\'
ab-.\'\'-a
rish a
rish.-
.-Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);