#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((C|c)h(a|ă|ẵ|ẳ)n)|((L|l)(e|ẻ)))[\s\[]*(\d+\s?-?\s?\d*)[\s\]]*([\w\s]*)$"
Local $sString = "Chẵn 0-100 Bạch Đằng" & @CRLF & _
"" & @CRLF & _
"Chẵn [0] 2-204 Trần Thanh Mại" & @CRLF & _
"Chẳn [0] 460-530 Kinh Dương Vương" & @CRLF & _
"Chẳn [0] 460-532 Kinh Dương Vương" & @CRLF & _
"" & @CRLF & _
"Chẳn [100-262] Quốc lộ 13" & @CRLF & _
"Chẵn 0 - 364 Phố Huế" & @CRLF & _
"Chẵn 0 - 44 Tây Tựu" & @CRLF & _
"Chẵn 0-100 Bạch Đằng" & @CRLF & _
"Chẵn 0-100 Ngõ 124 Âu Cơ" & @CRLF & _
"Chẵn 0-110 Đường Vành Đai" & @CRLF & _
"Chẵn 0-110 Trâu Quỳ" & @CRLF & _
"Chẵn 0-112 Đường Ô Chợ Dừa" & @CRLF & _
"Chẵn 0-116 Đường số 8" & @CRLF & _
"Chẵn 0-118 Bình Trị Đông" & @CRLF & _
"Chẵn 0-128 Nguyễn Sơn" & @CRLF & _
"" & @CRLF & _
"Lẻ 1-13 đường Thạnh Lộc 29" & @CRLF & _
"Lẻ 1-131 Đường số 4" & @CRLF & _
"Lẻ 1-131 Hoàng Hoa Thám" & @CRLF & _
"Lẻ 1-131 Kênh Mười Chín Tháng Năm" & @CRLF & _
"Lẻ 1-131 Nguyễn Phúc Chu" & @CRLF & _
"Lẻ 1-131 Trần Quang Cơ" & @CRLF & _
"Lẻ 1-131 Trần Văn Kỷ" & @CRLF & _
"Lẻ 1-133 Ấp Chiến Lược" & @CRLF & _
"Lẻ 1-133 Bạch Đằng" & @CRLF & _
"Lẻ 1-133 Khánh Hội" & @CRLF & _
"Lẻ 1-133 Nguyễn Thiện Thuật" & @CRLF & _
"Lẻ 1-134 Trần Hưng Đạo" & @CRLF & _
"Lẻ 1-135 Đặng Chất" & @CRLF & _
"Lẻ 1-135 Hoàng Hoa Thám" & @CRLF & _
"Lẻ 1-135 Lý Phục Man" & @CRLF & _
"Lẻ 1-135 Nguyễn Phong Sắc, Cầu Giấy, Hà Nội" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")