$re = '/^(?:(?:To:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,})|(?:CC:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,}))(?!.*@(example1\.com|example2\.org|example3\.net)\b)/m';
$str = 'To:jerry@example1.com,larry@example1.com,berry@example1.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);