package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+?)(View)?$`)
var str = `Shell
ShellView
Console
ConsoleView
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}