package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?::\d+)?(?:,\d+(?::\d+)?)*$`)
var str = `11
1,2
2,3:7,9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}