$re = '/\b(?=([a-z0-9]+:.*?(?: (?:AND|OR) [a-z0-9]+:|$)))/m';
$str = 'ti: harry Potter OR kw: magic AND sprint: title OR ti: HARRY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);