$re = '/\s(?=[^\s]+(.*?GHz)$)/i';
$str = 'Intel Core i3-4170 3.7GHz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);