package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b[^\s]*GHz\b`)
var str = `Intel Core i3-4170 3.7GHz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}