$re = '/e.?n$|en.?$/im';
$str = 'attend
attained
bean
maden
ebnb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);