import Foundation
let pattern = #"((ltm virtual) ([a-zA-Z0-9_-]*) ({(?:[^{}]++|\g<4>)*}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Some Garbage text
ltm virtual The_Name_51244_sdfasfdasd {
address-status yes
enabled
fallback-persistence none
profiles {
/Common/GLOBAL_PROFILE {
context all
}
/Common/http {
context all
}
}
rate-class none
rules {
/Common/X-F-F
}
log-profiles none
source-address-translation {
pool SOME-SNAT-POOL
type snat
}
source-port preserve
vlans {
Vlan1111
}
service-down-immediate-action none
service-policy none
source 0.0.0.0/0
}
barbage text
ltm virtual The_Object_51244 {
address-status yes
enabled
fallback-persistence none
profiles {
/Common/GLOBAL_PROFILE {
context all
}
/Common/http {
context all
}
}
rate-class none
rules {
/Common/X-F-F
}
log-profiles none
source-address-translation {
pool SOME-SNAT-POOL
type snat
}
source-port preserve
vlans {
Vlan2222
}
service-down-immediate-action none
service-policy none
source 0.0.0.0/0
}
Trailing garbage text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)