$re = '/^(?:[0-3](?:\.[0-9]+)?|4(?:\.[0-4][0-9]*)?|4\.50*|-[0-9]+(?:\.[0-9]+)?)$/m';
$str = '-1
-1.23
-0.005
0.123
1
1.0
1.1
2.2
3.3
4
4.4
4.499999999
4.5
4.50000
4.500001
5
10
10.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);