package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:==)`)
var str = `alabaster==0.7.9
arrow==0.8.0
awesome-slugify==1.6.5
Babel==2.3.4
binaryornot==0.4.0
blessings==1.6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}